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Figure 1: Selecting the ARX CoSign Printer 

Figure 1: OmniSign Window 

CoSign Quick Guide Signing PDF Files 
with OmniSign 

This chapter describes how to use the CoSign® 
OmniSign application to manage digital signature 
related operations in PDF documents. 

Launching OmniSign 
To launch OmniSign for PDF documents: 

 Right-click on the file name and select Sign 
with CoSign. OmniSign is launched. 

The OmniSign window (Figure 1) includes several 
elements:   
 

 Navigation bar – Navigate and control the 
zoom level of the document being viewed. 

 Main window – Displays the currently open 
PDF document/s in Static or Cascading mode. 

 Signatures Panel – Enables you to view all 
signed and unsigned signature fields, and 
perform various operations on the signature 
fields.  
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Figure 2:  OmniSign Toolbar 

 

 Toolbar - Enables you to perform various signature related operations, such as creating and signing 
a new signature field in the PDF document. (Figure 2)  

 

 

 

Creating and Signing a Digital Signature Field 
You can create and sign a digital signature field in a single operation. 

To create and sign a digital signature field:  

 Click  in the Toolbar (Figure 2), or select Signatures  Sign 
from the Menu bar.  

 In the main window (Figure 1), place the mouse on the desired location 
of the new signature field. Click and drag to create a new signature 
field, and size it as desired. Release to create the signature field.   

 The standard Signing Ceremony dialog box appears, displaying your 
default signature. (Figure 3) 

 Click Sign. A new, signed signature field is created. (Figure 4) 

 

Inserting a Digital Signature Field without Signing 
It is possible to insert a digital signature field without signing it.  This is useful 
when designing a document template.  
 
To create a digital signature field:  

 Click  in the Toolbar, or select Signatures  Place Digital 
Field from the Menu bar.  

 In the main window, place the mouse on the desired location of the new 
signature field. Click and drag to create a new signature field, and size it 
as desired. Release to create the signature field. A new signature field is 
created. (Figure 5)  

 To change the shape or size of the signature field, click and drag any of the 
handles on the corners of the field. You can also drag the entire signature field 
to a different location by clicking inside the rectangle and dragging it.  

 To change the default signature settings for this signature field, right-click  

inside the signature field and select Settings. Or, select Settings from the 
Options drop-down menu located just above the signature field. (Figure 6) 

Figure 4: Signed Signature Field 

Figure 6:  New Signature Options 

Figure 3:  Signing Ceremony Dialog 
Box with Default Signature 

Figure 5:  New Signature Field 
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Signing an Unsigned Digital Signature Field 
To sign an unsigned digital signature field:  
 

 Double-click the signature field or select Sign from the Options drop-down menu. (Figure 6) 

 The standard Signing Ceremony dialog box appears, displaying your default signature.  

 Click Sign. A digital signature operation is performed and your signature appears.  

Inserting and Signing Electronic Signature Fields  
You can incorporate electronic signatures into a PDF document. An electronic signature is a graphical 
image of a handwritten signature. Electronic signatures are suitable for certain applications such as 
Point of Sale purchases. In a Point of Sale scenario, the customer may electronically sign a sales 
contract. Then, the local sales person can digitally sign and effectively seal the document.  For more 
information on inserting and signing electronic signature fields, please refer to the CoSign v5.4 User 
Guide (Chapter 8: Inserting an Electronic Signature Field).  

Performing a Multi-Page Signature Operation 

You can add a digital signature field to multiple pages of a PDF document 
in a single operation. This operation adds a new unsigned signature 
field to subsequent pages of a document based on the location of 
the first signature field you create in the document. Multi-page 
signing is suitable for contract-type documents, CAD drawings, or 
any type of document that may require signatures or seals on multiple pages.  

To create a multi-page signature field: 

 Go to the first page that requires a signature.  

 Open the drop-down menu using the arrow on the Sign button . (Figure 7) 

 Select Multi-Page Signatures.  

 Click the mouse to indicate the top left corner of the new 
signature field. An empty signature field is created, and the 
Multi-Page Signatures dialog box appears. (Figure 8)  

 Optionally drag or resize the empty signature field or click 
Settings to specify signature settings for this signature.  

 Click Sign. The standard Signing Ceremony dialog box appears.  

Select or enter the relevant information.  

 The signature field is signed.  

On each subsequent page, the new signature field is created at the same location, with the same 
appearance and settings. 

Figure 7:  OmniSign – Signing Options 

Figure 8:  Multi-Page Signatures Dialog Box 

http://www.arx.com/files/DOCUMENTS/Support/CoSign_User%20Guide%20V5_4%20-%20Regular%20Client.pdf#page=122�
http://www.arx.com/files/DOCUMENTS/Support/CoSign_User%20Guide%20V5_4%20-%20Regular%20Client.pdf#page=122�
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 Click Sign to sign the current page and display the next page.   

-     If you do not want to sign a page, click Skip.  The next page will be displayed. 

- At any page, you can click Settings to change the signature settings from the current page 
onward.  

 Click Done to end the Multi-Page Signatures operation.  

Validating All Signatures  

To validate all signatures, click    in the Toolbar, or select Signatures  Validate all Signatures 
from the Menu bar. 

The Signatures Panel (Figure 1) displays the validity status of each signature. In the main window, a 
valid signature appears with a green check mark, an invalid signature appears with a red cross mark, 
and an unknown (not yet validated) signature appears with no indication. 

-  A green check  indicates a valid signature. 

-  A red “X”  indicates an invalid signature. 

 

Performing Operations on a Signature Field 
You can perform various operations on a signature field. To view these operations, you may:  

 Click the Options drop-down menu located above the signature field. (Figure 6) 

 Right-click on the signature field. 

 Left-click a signature field in the Signatures Panel. (Figure 1)  

The available operations include: 

 Sign – Signs or re-signs the signature field.  

 Certify – Performs a PDF signature operation that is “stronger” than the regular PDF signature 
operation as described in the CoSign v5.4 User Guide (Chapter 7:  Certifying an Adobe Acrobat 
Document). When a document is certified, you can specify one of the following certification 
modes:  

- No further changes allowed – No changes are permitted to the PDF document.  

- Form filling & signing allowed – You may enter data in forms, and sign existing signature fields 
in the PDF document.  

- Annotations, form filling & signing allowed – You may add annotations to the document, enter 
data in forms, and sign existing signature fields in the PDF document.  

The Certify operation is disabled if there is a signed field in the document.  

 Validate – Validates the digital signature. The display of the signature in the main screen is 
refreshed to reflect the validation state of the signature.  

 Clear – Clears the digital signature. This results in an empty signature field.  

http://www.arx.com/files/DOCUMENTS/Support/CoSign_User%20Guide%20V5_4%20-%20Regular%20Client.pdf#page=106�
http://www.arx.com/files/DOCUMENTS/Support/CoSign_User%20Guide%20V5_4%20-%20Regular%20Client.pdf#page=106�
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 Remove – Removes the digital signature as well as the signature field from the document. This 
operation is disabled if there is a signed field in the document.  

 Settings – Displays the signature settings.  Signature Settings can be changed if the field is not 
signed.  The operation is disabled if there is a signed field in the document.  

 Details – Displays the digital signature status and certificate status. 

Configuring Settings for a Single Signature 
You may configure the settings and appearance of an individual signature.  The Signature Settings 
dialog box contains the parameters that influence the signature appearance (Figure 9). 

 

To access the Signature Settings dialog box: 

 Select Settings from the Options drop-down menu located above the 
signature field. (Figure 6) 

 In the Signature Settings dialog box, configure General parameters, 
Appearance, and the Date & Time Format.  

 The General section allows you to specify a name for the signature 
field (Field name), specify whether the required signature is digital 
or electronic (Signature type), and select whether to prompt a 
signer to enter a reason during signing (Prompt for signature 
reason).  

 The Appearance section allows you to select the elements that are 
displayed in the signature field.   

-   Show signature field – Select whether to display the signature field. 
When this box is unchecked, the signature appearance and the 
signature size and position settings are disabled, and the signature 
field is hidden. This parameter is not relevant for electronic 
signatures. 

- Display caption (labels) – Indicates whether to use captions such as 
“Date,” “Reason,” and “Signed by” for the fields that will be 
displayed in the signature field. 

- Selecting Graphical signature, Initials, Logo, Date and time, 
Signer’s name, Title, and/or Reason will display these elements in 
the signature field. 

- Graphical signature location – Specifies the location of the visible 
signature. 

 
 

Figure 10:  OmniSign Default Signature 
 Settings – General 

Figure 9:  Signature Settings 
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Figure A: Selecting the  
ARX CoSign Printer 

Configuring Default Signature Settings 
You can configure the default appearance and other general settings of newly created digital and 
electronic signatures.   

 Click  in the Toolbar, or select Tools  Settings from the Menu bar. The OmniSign Settings 
dialog box appears. (Figure 10) 

 The Digital Signature and Electronic Signature tabs allow you to select specific elements to be 
displayed in the signature field.    

 Click the General tab to configure the default signature settings.  

- General Settings – Choose to display tip pop-ups at startup, open new documents in the active 
OmniSign window, validate all signatures upon opening a PDF file, or activate One-touch 
signature.    

- Saving Options – Specify where a signed PDF is stored and whether to delete the original file. 
- Signature Date & Time Format – Specify date and time format. 

For a more detailed description of OmniSign functions, please refer to the CoSign v5.4 User Guide 
(Chapter 8: OmniSign – Signing PDF and Non-PDF Files). 

 

Appendix A:  Converting Files to PDF Using OmniSign 
If your file is not in PDF format, you can easily convert it to PDF using OmniSign.   

To convert to PDF using OmniSign: 

 Open the file. 

 Select File > Print. The Print dialog box appears. (Figure A displays 
the standard Print dialog box that appears in Microsoft Word). 

 Select ARX CoSign, and click Print.  

Clicking Print triggers the PDF conversion process and simultaneously 
launches the OmniSign application, which displays the newly created PDF 
file.  

Once the file is converted to PDF, you may create and digitally sign 
signature fields using OmniSign. 
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